A forum for reverse engineering, OS internals and malware analysis 

 #33027  by hackr8
 Sat Jun 29, 2019 12:40 pm
For some reason, powershell_ise crashes upon launch. I noticed this a few months ago. It worked perfectly before. The powershell console works perfectly. Only the ISE crashes. My OS version is x86 windows vista 6.0.6002. and my powershell version is 1.0. Can you help me? Here is a screenshot of the crash message:
powershellcrash.JPG (65.74 KiB) Viewed 112 times
Every advice or solution is appreciated...
 #33075  by R136a1
 Sun Jul 14, 2019 2:02 pm
You can start by looking at the exception description to get an idea what might caused this: https://docs.microsoft.com/en-us/dotnet ... mework-4.8 (look at the remarks)

As powershell_ise.exe is a .NET application, you can throw it into a decompiler like dnSpy and debug it to see where it crashes.
 #33077  by hackr8
 Mon Jul 15, 2019 12:22 pm
Unfortunately, dnspy is not supported on my pc due to my OS being windows vista and my net framework version being below the required one. Additionally, i found out that no Wpf application will load on my pc and when i try to make one with visual studio 2008 the designer crashes. If i try to debug it, it throws a TypeInitialization exception. I think my pc is dying. Please help.
 #33090  by hackr8
 Fri Jul 19, 2019 10:19 am
I tried reinstalling .NET Fremework but the problem remained. About reinstalling Powershell, i found a microsoft link with the powershell update but unfortunately i couldn't find anything about Powershell ISE... The update does not include it. I think there are only two ways for the problem to be solved: either by finding a way to reistall powershell_ise or by finding another computer whose powershell installation is not broken and getting it from there.
 #33092  by hackr8
 Sat Jul 20, 2019 6:09 pm
I installed the same powershell version on a vista vm and it was working there. I tried copying the whole Powershell folder from the vm to my pc but nothing changed. This means that the files are not corrupt. Are there any registry entries or hidden files that might be causing this problem?